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Introduction
With Smultron you can easily write and edit text. It is a text editor for the rest of us which is 
both easy to use, elegant and very powerful.

Uses

• Do you ever quickly want to just write down some text without worrying about formatting?

• Do you ever want to quickly look and at text in many different documents?

• Do you ever want to edit or create a web page?

• Do you ever need to write or change a script?

• Do you ever quickly want to write down a to do list?

• Do you ever want to find and change portions of your text in multiple documents?

• Do you want to access your documents on all your Mac thru iCloud?

Smultron can do all this for you and much, much more

Simple

• Smultron does not complicate your experience and you can directly start to write or edit 
text

• It colors the content in different colors depending on what your text does

• You have all your open documents easily accessible in a list with icons which shows the 
content

Powerful

• For the more advanced users Smultron is a fully featured text editor 

• Smultron can also use regular expressions

• You can run commands and scripts and insert the result

• You can also have snippets of code readily available when you need it

• There is also full support for all text encodings and you can also preview HTML-documents 
directly
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Special Features
iCloud support
You can move documents to iCloud and access them on all your Macs.

view in fu# screen
You can edit the document in full screen (nothing else is visible, not even the menu bar, but you 
can show it by moving your mouse to the top of the screen) by choosing the command in the 
View menu.

functions
You can see a list of all the functions in your document in the Tools menu or with the toolbar 
item.

encodings
Only a small selection of the available encodings are shown to begin with. You can choose to see 
more under Advanced in Preferences. If you think that the characters are wrong you can test to 
reload the text with another encoding in the Text menu (this option is only available if there are 
no edits made to the document).

snippets
Snippets are pieces of text that you use often or want easy access to. You create a snippet by 
using the command in the Tools menu. If you include one or several %%s in the text, they will be 
replaced by the current selection, if some text is selected when the snippet is inserted. And if you 
include a %%c the cursor will be placed at that position after the snippet has been inserted.
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preview
With this you can preview the HTML in the current document. If e.g. you are using a FTP-
program to edit a file you set the base URL of that file so that all relative links are loaded, e.g. for 
images and css-files. If you are editing the file index.html for the site www.apple.com you can put 
http://www.apple.com/ as the base URL for all the images to load correctly (as long as you are 
connected to the internet of course).

commands
You can run commands from within Smultron if you e.g. want to compile some code or make a 
file executable, or if you want e.g. to validate an HTML document or insert e.g. the current date. 
If there is a result from the command it can be shown in the current text if you have chosen it to 
be inline or otherwise in a separate window. You can include %%p or %%d in your command to 
get the full path or directory of your current document. This means that you don't have write the 
path of the document but you can e.g. compile the current document easily. If you include %%s 
the selected text will be saved into a temporary file and %%s exchanged with the path to that 
file. You can also select some text and run that text as a command inline. E.g. if you write 
"date" (without the quotes) and select it and choose Run Selection Inline from the Tools menu it 
will be replaced by the current date.

run text
When you choose Run Current Text in the Tools menu the text is saved to a temporary file and 
then ran with the command chosen in Preferences, normally /bin/sh. Any result is displayed in 
the Commands window.

appleScript
Limited AppleScript support is included in Smultron. See AppleScript Editor in Utilities for 
more information what commands are available in for Smultron.

auto-completion
You can set in the Preferences whether Smultron should suggest the completed word 
automatically. Otherwise you can press F5 or Option-Esc to get the list. If you don't find a match 
in what's been suggested you can press Esc or just continue writing.

http://www.apple.com
http://www.apple.com
http://www.apple.com
http://www.apple.com
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comment or uncomment selection
Inserts whatever the syntax definition has defined as single-line comment for the current 
document, e.g. // for a PHP-document, at the beginning of the line if the first line of the 
selection isn't already commented, otherwise it removes the comments. The menu item is only 
available if the used syntax definition has a defined single-line comment.

services
If you choose Services from "application"-menu you can make Smultron open the currently 
selected file, insert the selection into the current document or create a new document with the 
current selection.

advanced find
Multi-document search and replace with the option to use regular expressions. The regular 
expression engine is ICU. You can find more information about it here: http://www.icu-
project.org/userguide/regexp.html

show invisible characters
Shows a symbol for characters that are usually not seen, i.e. space, tab and new-line.

print settings
When you choose Print... you can choose Smultron in the pop-up menu and choose which font 
to use. You can also choose if you want to print the header and if you only want to print the 
current selection. It is also possible to set the smallest margin you want to use and if you want to 
print the syntax colors.

remove needless whitespace
Removes any possible spaces or tabs after the text and before the line break.

http://www.icu-project.org/userguide/regexp.html
http://www.icu-project.org/userguide/regexp.html
http://www.icu-project.org/userguide/regexp.html
http://www.icu-project.org/userguide/regexp.html
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shi' le' & right
Remove tabs and spaces to shift to selected text to the left or insert tabs to move it to the right.

line numbers
If you don't want to show the line numbers choose Hide Line Numbers in the toolbar or in the 
View-menu.

syntax colors
If you don't want to show the syntax colors choose Hide Syntax Colors in the toolbar or in the 
View-menu.

line wrap
If you don't want the lines to wrap at the end of the window choose Don't Line Wrap in the 
toolbar or in the Text-menu.

status bar
If you don't want to show the Status Bar choose Hide Status Bar in the View-menu or if you just 
want to not show some particular information set the Preferences to your wish.

close tag
This tries to find the correct tag to close by calculating the number of tags that has been closed 
and opened (skipping tags like <br> and <hr />) so it will find the last tag that was opened but not 
closed. After it has found the correct one it insets the closing tag adding a / to the opening tag 
e.g. </head>. Note that this feature only works with tags surrounded by < and >.

prepare for xml
This changes all occurrences of &, < and > in the selection into &amp;, &lt; and &gt; so that the 
text can be used in a XML-file.
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Preferences
General

text font
Set the font and size for the text of the document and also for its line numbers.

text color
Set the color of the text of the document.

background color
Set the color of the background of the document but not for its line numbers.

auto save
Whether Smultron should automatically save the documents or if you need to manually save 
them.

create new documents in the same place as the previous
Whether Smultron should create new documents in the same place as the previous which will 
cause less clutter and it will appear as just one window (and one can still switch between them in 
the usual way) but with all the advantages of having several window, like e.g. app exposé.

line endings
Different operating systems uses different invisible characters to denote that you want a new line. 
This option gets you to choose to which line ending you want when you save your document. If 
you don't have a particular need you can usually set it to “Leave unchanged” which leaves the line 
endings as it is for documents that you have opened. New documents uses the Unix standard.
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su(est automatica#y, a'er delay
Whether the list of matching word-completions should appear automatically and how long (in 
seconds) after the last pressed key that the list of matching words should appear.

include standard words
Whether the word common English words should also be included in the auto-completion 
instead of just the words from current syntax definition.

status bar: length of document
The number of characters in the document

status bar: length of selection
The number of characters in the current selection, if less than two characters are selected this 
won't show in the status bar

status bar: position
Shows first the location of the cursor in the line and then the location of the cursor in the whole 
document.

status bar: text encoding
Show which encoding the current document has; you can change it through Text Encoding in the 
Text-menu and also set the Preference as you like in the Open & Save tab.

status bar: syntax definition
Show which syntax definition is set for this document; you can change it through Syntax 
Definition in the View-menu and also set the Preference as you like in the Syntax Coloring tab. 
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status bar: word count
Show how many words are in the document

Advanced - Editing

indent with spaces, not tabs
Writes spaces and not a tab when the tab key is pressed. How many spaces are determined by Tab 
width in Appearance.

tab stops
Whether you want to use tab stops or not, i.e. if it should calculate how many spaces are needed 
to get to the next stop, which is defined by "Tab Width", instead it will insert a fixed number of 
spaces when pressing tab (if one has chosen to insert spaces instead of a tab when indenting).

tab width
This sets how wide a tab should be; it calculates the width by checking the width of the number 
of spaces you state here in the current font.

indent width
This sets how wide an indent should be; it calculates the width by checking the width of the 
number of spaces you state here in the current font.

auto-insert a closing )
Automatically inserts a ) when you write a (.

auto-insert a closing }
Automatically inserts a } when you write a {.
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show matching braces
When you write a ), } or ] Smultron briefly highlights the corresponding (, { or [ if it can find it, 
otherwise it beeps.

indent new lines the same as the line above
After you press Enter places the cursor on the new line where text starts on the preceding line.

treat { and } inte#igently
Indents one step on the next line if the last character on the preceding line is a { and shifts the 
characters on the line to the left when inserting a } if there are no letters before.

fu# screen document width (in percent)
How wide the document should be in full screen mode (from 10% to 100%)

show page guide, at column
If you want to display a faint line after e.g. 80 characters. This only works correctly when you use 
a monospaced font.

highlight current line
Changes the background color of the current line so it is more easily seen.

color for invisible characters when shown
The color that the usually invisible characters have when they are shown.

preview parser
When the preview is shown this setting decides what is used to interpret the code into the seen 
preview.
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run text
When you choose Run Text in the Action menu the text is saved to a temporary file and then ran 
with this command.

Advanced - Encodings
Choose whether to always use a particular text encoding when you open a file or whether to 
guess the encoding of the document. Smultron guesses by trying to see if any information about 
the encoding is saved along with the file otherwise it checks for “charset=” or if it can't find that, 
search for “encoding=” and map the encoding to what follows after that. If it can't find the 
encoding this way it checks for either EFBBBF, FEFF or FFFE at the beginning of the file and, if 
found, set the encoding to UTF-8 or UTF-16. If it can't guess by any of these means it sets it to 
the chosen encoding. Smultron checks to see if the document has been saved with a particular 
encoding (it is saved as a piece of meta-data) and, if so, it always uses that one.

Advanced - Syntax Colors

active - color
Here you can turn on syntax coloring for each part and decide which color Smultron should use. 
See Syntax Coloring for a description of what the different parts are.

only color ti# the end of the line if it can't find closing tag
Only continue to color till the end of the line instead of the rest of the document if just the start 
tag is found and not the closing tag in e.g. a multiline comment

color multi-line strings
Color a string even if it has line-breaks in it. 
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Advanced - Syntax Definitions

use definition
Here you choose whether the Smultron should guess from the extension which syntax definition 
to use (e.g. if the extension of the document is .html it will use HTML) or if it should always use 
a particular syntax definition). If the document does not have an extension it tries to guess by 
checking the first line of the document for e.g. #!/usr/bin/perl and then maps it to the syntax 
definition; if it can't guess, it will use the Standard one.

the table
The table lists all the extensions that are mapped to each language. If you add or change an 
extension just double-click in the Extensions-column and change the extension (the extensions 
are space separated and there should be no dots). Smultron uses the first language (alphabetically) 
that has the extension so if many languages share the same extension make sure that no language 
above also has the extension. 
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Expert Preferences
Turn off Smultron and run these commands in Terminal (which you can find in /Applications/
Utilities) and then start Smultron again.

end file with line feed
By writing:

defaults write com.peterborgapps.Smultron4 AlwaysEndFileWithLineFeed -bool 
YES
Smultron will check to see if the document ends with a line feed character (\n) and if not, it will 
add one. Exchange YES with NO if you want to return to the default state.

delay before preview should update live automatica#y
By writing:

defaults write com.peterborgapps.Smultron4 LiveUpdatePreviewDelay 5
you will change how long the delay will be after the last key is pressed before the preview should 
automatically update if you have checked the "live Update" box. Default value is 1.

quotes around directory when using %%d
By writing:

defaults write com.peterborgapps.Smultron4 PutQuotesAroundDirectory -bool 
NO
Smultron won't put quotes around the path to the directory referenced by %%d. Exchange NO 
with YES if you want to return to the default state.

preview font size
By writing:

defaults write com.peterborgapps.Smultron4 PreviewDefaultFontSize -int 18
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Smultron will change the default preview font size to 18 instead of 16 (you can use any “integer” 
value, i.e. a number without decimals).

use hex rather than rgb when inserting color values
By writing:

defaults write com.peterborgapps.Smultron4 
UseRGBRatherThanHexWhenInsertingColourValues -bool NO

Smultron will insert color values when choosing it in the Tools menu with hex values instead of 
rgb values. Exchange NO with YES if you want to return to the default state.

open untitled document
By writing:

defaults write com.peterborgapps.Smultron4 OpenUntitled -bool NO
Smultron will not open an untitled document when no other document is to be opened at 
startup. Exchange NO with YES if you want to return to the default state.
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Syntax Coloring
Smultron syntax colors your document if you have chosen so with the syntax definition of your 
choice.

the colors
The easiest way to learn which colors to choose in 
Preferences is to test on a document which you know well. 
But here to the right is an image of a php-code example 
which might help you.

 “<?php” and everything in grey until the closing tag (not 
shown here) are Instructions. “<head><title>” are 
Commands. “echo” is a keyword.

change a syntax definition
The syntax definitions are defined in plist files in the Application bundle (ctrl-click on Smultron 
and choose Show Package Contents -> Contents -> Resources) e.g. html.plist for HTML 
documents. (Remember to treat special characters in the standard xml-way e.g. &lt; instead of < 
and if you don't want leave a string empty please do it like this <string></string>.)

The keys are: (I use php as an example within parentheses):

beginCommand
(<) to show html commands 

endCommand
(>)

beginInstruction
(<?) to start a block of code

endInstruction
(?>)

beginVariable
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($) the character (or any of the characters) that signals that it is a variable

endVariable
(:;(){}=[]+-/.,*!?%&><\) anyone of these characters ends the variable name

firstString
(") only one character is recognized for the strings

secondString
(')

firstSingleLineComment
(//) a comment till the end of the line

secondSingleLineComment
(#) another comment till the end of the line

beginFirstMultiLineComment
(/*) the start of a multiline comment

endFirstMultiLineComment
(*/)

beginSecondMultiLineComment
(<!--) to allow e.g. html comments in php-code

endSecondMultiLineComment
(-->)

keywordsCaseSensitive
(<false/>) set either to </false> or </true> if you want the keywords to be case sensitive

recolourKeywordIfAlreadyColoured
(<false/>) if you want a keyword to be colored as a keyword even if its already been colored as a 
command

keywords

(<string>and</string>) a list of keywords

autocompleteWords
(<string>auto-complete this word</string>) a list of words to add to the auto-completion

functionDefinition

(<string>a regular expression</string>) a regular expression that finds the beginnings of functions 
in the document
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removeFromFunction

(<string>a string</string>) a string that is removed from the function name, e.g. if the function is 
defined by having the word function in front of it, it can be removed from the list to make it 
easier to read

attributes

you cannot define this yourself but it defined as the word before a “=” in a command

optional values
You can also add any of four optional strings which adds or removes characters from the 
character sets that decide where a keyword can start or end. The four keys are:

excludeFromKeywordStartCharacterSet

excludeFromKeywordEndCharacterSet

includeInKeywordStartCharacterSet

includeInKeywordEndCharacterSet
just add all characters you want, to the string to these keys.

add new definition
If you want to add a new definition, you must create a new file named languagename.plist and fill 
it with information as per above (it is easiest to copy an a plist file and only change what you 
need). Then you add a (or open the existing) SyntaxDefinitions.plist file in the /Users/<your home 
folder>/Library/Application Support/Smultron4 folder and add a dictionary into the file. The 
best way to do this is to make a copy of the SyntaxDefinitions.plist that's in the application 
bundle and start from that one. An example is below:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://
www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<array>

<dict>

	 <key>name</key>

	 <string>PHP</string>

	 <key>file</key>

http://www.apple.com/DTDs/PropertyList-1.0.dtd
http://www.apple.com/DTDs/PropertyList-1.0.dtd
http://www.apple.com/DTDs/PropertyList-1.0.dtd
http://www.apple.com/DTDs/PropertyList-1.0.dtd
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	 <string>php</string>

	 <key>extensions</key>

	 <string>php php3 phtml phtm</string>

</dict>

</array>

</plist>

The name-key is what shows up in the View menu and the file-key is what you name your file 
minus the .plist extension. The extensions-key lists the various extensions your language can 
have, space separated and without dots.
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FAQ
what is smultron?
Smultron is a text editor which is both easy to use and powerful and it is written in Cocoa for 
Mac OS X.

requirements?
OS X Lion (10.7) or later

the name?
Smultron is the Swedish name for wild strawberry (fragaria vesca).

how to delete snippets, commands etc.?
Select it and press Backspace on the keyboard.

how do I assign a keyboard shortcut to snippets and commands?
You do this in System Preferences - Keyboard - Keyboard Shortcuts. Choose Application 
Shortcuts and then press + and then choose Smultron and write the exact name of the snippet or 
command.

how can I open “hidden” files
When you are in the standard open dialog just press Command Shift and a dot
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where are things saved?
Snippets, Commands are saved in your preference files and that can be found here: <your home 
folder>/Library/Preferences/com.peterborgapps.Smultron4.plist. You can see that folder in 
Finder by choosing Go to Folder in the Go menu and then write: ~/Library/Preferences/

can I import my settings /om version 3 of Smultron?
Not automatically as they are two separate apps but you can copy the file <your home folder>/
Library/Preferences/com.peterborgapps.Smultron.plist and name it <your home folder>/Library/
Preferences/com.peterborgapps.Smultron4.plist All settings which are the same will then use the 
old settings.

can I import snippets and commands /om version 3 of Smultron?
Not automatically as they are two separate apps but the easiest way to do it is just to open both 
apps and copy and paste between the apps, if you only have a few. If you have many that you need 
to import please contact me and we’ll discuss different options.

how can I move a document to iCloud?
Make sure that the document you are using has been saved somewhere and then choose Move 
Document to iCloud from the File menu (and make sure that iCloud is activated in System 
Preferences and Documents & Data is turned on). That’s all you need to do. And then you can 
open it on every computer you have connected to that iCloud account by choosing Open from 
iCloud… in the File menu or click on the icon in the toolbar.

how do I open a document in iCloud?
Choose Open from iCloud… in the File menu or click the toolbar button and then select the 
document and either double-click it or press Enter on your keyboard.

how can I delete a document /om iCloud?
You can do it in two ways; either close the document in Smultron and the go to System 
Preferences - iCloud - Manage… and choose Smultron and then delete the document you want, 
or choose Move Document from iCloud in the File menu and then delete the local file in the 
normal way.
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how do I change the size of the icons and the text in Documents?
Smultron uses the setting in the system which you can set in System Preferences - General.
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Troubleshooting
Make sure that you are running the latest version. Then you can check to see if you have any 
Input Managers installed. Check the following directories:

• /Library/Application Support/SIMBL/Plugins/

• /Library/InputManagers

• <your home folder>/Library/InputManagers

and try to disable any there and restart Smultron and see if the problem persists.

If that doesn't help you can try to move aside (e.g. move temporarily to the desktop) the 
Smultron preference file so every setting will be reset to the default:

• <your home folder>/Library/Preferences/com.peterborgapps.Smultron4.plist

If nothing works you can try to download a fresh version of Smultron to make sure that the 
application hasn't been damaged in any way.


